phpstorm 安装laravel-ide-helper失败的解决办法

08-02 16:43 字数 723 阅读 30

直接用官方的命令 composer require --dev barryvdh/laravel-ide-helper ,报错如下:

Problem 1
    - barryvdh/laravel-ide-helper 2.12.x-dev is an alias of barryvdh/laravel-ide-helper dev-master and thus requires it to be installed too.
    - barryvdh/laravel-ide-helper[dev-master, v2.12.0, ..., v2.12.3] require illuminate/console ^8 || ^9 -> found illuminate/console[v8.0.0, ..., 8.x-dev, v9.0.0-beta.1, ..., 9.x-dev] but these were not loaded, likely because it conflicts with another require.
    - Root composer.json requires barryvdh/laravel-ide-helper ^2.12 -> satisfiable by barryvdh/laravel-ide-helper[v2.12.0, ..., 2.12.x-dev (alias of dev-master)].

解决办法:

安装低版本的即可。

执行命令

composer require --dev barryvdh/laravel-ide-helper 2.8
0人点赞>
关注 收藏 改进 举报
0 条评论
排序方式 时间 投票
快来抢占一楼吧
请登录后发表评论